Volusion supports exporting data to a variety of file formats, including industry-standard XML. One of the greatest benefits of being able to export your store data to XML format is that XML data structure is simple and supported in a wide variety of computer applications and online services.

This article will show you how to import XML-formatted data from your store into Microsoft Access as well as export that data back to XML format.

Getting Started

Note that these instructions are specific to Microsoft Access 2003 and 2007. This article assumes that you have already exported one or more database tables from your store to an XML or CSV file.

Also note that you can't import or export Access files with an .mdb extension.

With your XML file ready, you can import your store data to Microsoft Access as follows:

Importing the XML File in Access 2003

  1. Open Microsoft Access 2003 and create a new, blank database.
  2. From the Access menu bar, select File > Get External Data > Import.
  3. From the File Type menu, select XML and then choose your XML file.
  4. Click OK and you're done!

Importing the CSV or XML File into Access 2007 or 2010

  1. Open Microsoft Access 2007 and click on New Blank Database.
  2. Enter a filename for the database in the File Name field and click Create.
  3. From the Access menu bar, select External Data.
  4. From the Import section select XML File or Text File and browse to XML file.
  5. Click OK and click OK again on the following pop-up window and you're done!

You should now see the name of the database table from your file export listed within the Access database settings. Click on this table to view its contents. You can edit the contents of your database table in Access, save to the Access file, export it in XML, or save as a CSV text file so that it can be imported back into Volusion.

Converting from MDB to CSV in Access 2010

To convert your Microsoft database file to a CSV file:

  1. Open your Microsoft Access database.
  2. Under the External Data tab, click Text File in the Export section.
  3. Enter a destination for your file or use the Browse tool, then click OK.
  4. In the Export Text Wizard, choose Delimited and click Next to continue.
  5. Choose Comma as the delimiter.
  6. Select Include Field Names On First Row.
  7. Set Text Qualifier to double quotation marks.
  8. Click Next, then click Finish.

Exporting the Access Database to XML or CSV in Access 2003

  1. Within Access, select the database table you want to export.
  2. Within the Access menu bar, click File and then Export.
  3. In the File Type menu, select XML or CSV as appropriate and then enter a name for your database and click OK.
  4. Click OK on the following pop-up window.

When Access has completed the export, your data will be contained within a newly-created file.

Exporting a Database to XML or CSV in Access 2007 or 2010

  1. Within Access, open the database table you wish to export.
  2. Within the Access menu bar, click External Data.
  3. To save as a text file for importing back in Volusion, click Text File.
  4. To save as XML, select More, and from the drop-down menu, select XML.
  5. For either file type, enter a file name for your database and click OK.
  6. Click OK or Finish on any following pop-up window.

When Access has completed the export, your data will be contained within a newly-created XML or CSV file.

Why Use XML?

XML is an industry standard. You can use XML to share your Volusion store data with many different types of web services and applications to extend your store's functionality and flexibility.

Did this answer your question?